Skip to main content

Compatibility

AvatarScriptLink.NET is built on .NET Standard 2.0. to support the widest range of .NET Framework, .NET, and Windows Server versions and features.

.NET Framework

.NET Standard 2.0 libraries are compatible with the following .NET Framework versions.

.NET FrameworkCompatible
4.8.1Yes
4.8Yes
4.7.2Yes
4.7.1Yes
4.7Yes
4.6.2Yes
4.6.1Yes*
4.6 and earlierNo

For .NET Framework v.4.6.1 projects, the recommendation is to upgrade to version 4.7.2 or higher due to several issue with consuming .NET Standard libraries. The AvatarScriptLink.NET NuGet package includes a version that specifically targets v.4.6.1 to address these issues if upgrading is not currently an option.

Check out the Microsoft Docs for more information on .NET Standard compatibility.

.NET and .NET Core

AvatarScriptLink.NET is compatible with .NET and .NET Core.

.NETCompatible
8.0Yes
7.0Yes
6.0Yes
5.0Yes
3.1 (Core)Yes
3.0 (Core)Yes
2.1 (Core)Yes
2.0 (Core)Yes
1.0 (Core)Yes

Windows Server

Windows Server support is based on the .NET Framework version you choose to use in your ASP.NET Web Application. These are the Windows Servers that can support .NET Framework 4.6.1 or higher.

VersionCompatible
Windows Server 2022Yes
Windows Server 2019Yes
Windows Server 2016Yes
Windows Server 2012 R2Yes
Windows Server 2012Yes
Windows Server 2008 R2Yes, with SP1
Windows Server 2008 SP2Maybe, requires .NET Framework 4.6.2
Windows Server 2008 or earlierNo

More information can be found on Microsoft Docs.